Voice Support not available
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 11:53 BST
Investigating
We are currently experiencing issues with our primary phone lines and are unable to take calls at this time. Our team is actively working to resolve the problem.

In the meantime, you can reach us on our secondary phone number: 0207 025 7130. Additionally, please feel free to contact us via our chat service or raise a support ticket at https://ticketing.123-reg.co.uk/.

We apologize for any inconvenience and appreciate your understanding.

Thank you for your patience.
Posted Jul 24, 2024 - 09:31 BST
This incident affected: 123-reg.co.uk (Customer Support).