Customer Support
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 07:47 BST
Investigating
For the time being, if you need any help or assistance, please raise a support ticket from: https://www.123-reg.co.uk/support/
Due to the ongoing incident, we are unable to offer guidance on Live Chat and Phones.
Your understanding is highly appreciated.
Posted Sep 17, 2024 - 16:37 BST