Generation 2 Mailboxes - Webmail Access Issues
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Aug 31, 2023 - 14:13 BST
Investigating
Customers are currently experiencing technical issues when attempting to access their Generation 2 mailbox via Webmail.
If you're affected by this issue, you can access your emails using one of the following methods:
1) Via third-party email clients such as Outlook and Gmail.
2) Via your Email & Office dashboard. For details on how to do this, please visit:
https://www.123-reg.co.uk/support/email/how-do-i-access-my-email-office-dashboard/
3) By entering 'email.your-mailbox-domain.com' into your browser bar (i.e. email.john-smith.co.uk).
We are looking into this issue and hope to have it resolved as soon as possible. We apologise for any inconvenience this may cause.
Posted Aug 31, 2023 - 10:44 BST