Account Login Issues
Incident Report for
123 Reg –
Resolved
This incident has been resolved.
Posted
Sep
17
,
2024
-
09:57
BST
Investigating
There are some customers who are unable to log in to their 123 Reg account.
This is currently under investigation.
Your patience while this is ongoing will be highly appreciated.
Posted
Sep
17
,
2024
-
08:59
BST
×
Subscribe to Incident
Subscribe to updates for
Account Login Issues
via . You'll receive .