We are continuing to monitor for any further issues.
Posted Jun 07, 2023 - 08:10 BST
Update
We are continuing to monitor for any further issues.
Posted Jun 06, 2023 - 15:08 BST
Update
We are continuing to monitor for any further issues.
Posted Jun 04, 2023 - 15:08 BST
Monitoring
Starting April 20 we're advising our customers to prepare for the migration of Generation 1 mailboxes on our new platform. The migration is scheduled to start mid-May. Please refer to the dates and action points below in order to ensure a smooth transition:
Forwarder limit set to 50: COMPLETED Removal of ‘Domain Reject’ email forwarding rules: COMPLETED Clean-up of invalid/unused items (i.e. catch-alls, forwarders, mailboxes): COMPLETED Update mailbox passwords: COMPLETED - PASSWORDS RANDOMISED Check mailboxes and associated domains exist in the same account: COMPLETED - INVALID MAILBOXES DELETED Reduce email forwarder total to 50 or less: COMPLETED - ALL FORWARDERS MIGRATED Reduce recipients for each email forwarder to 10 or less: COMPLETED - FORWARDERS WITH EXCESS RECIPIENTS DELETED Replace catch-all forwarders with catch-all mailboxes: COMPLETED- CATCH-ALL FORWARDERS DELETED Please read the following article for further details on these actions: