Email clients connection issue
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 07:59 GMT
Investigating
Some customers are currently experiencing technical issues when attempting to access their Generation 2 mailbox via third-party email clients like Outlook and Gmail.
If you're affected by this issue, you can still access your emails via Webmail.
We are looking into this issue and hope to have it resolved as soon as possible.

We apologise for any inconvenience this may cause.
Posted Feb 13, 2024 - 15:49 GMT
This incident affected: Email & Office (Email Hosting).