Account Login Issues
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Aug 02, 2023 - 15:49 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 02, 2023 - 15:25 BST
Investigating
Customers may experience issues when attempting to log in to their 123 Reg account.

We are currently investigating this issue and hope to have it resolved as soon as possible. We apologise for any inconvenience this may cause.
Posted Aug 02, 2023 - 14:56 BST
This incident affected: 123-reg.co.uk (Control Panel).