Professional Email Service Degradation
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Nov 02, 2023 - 10:17 GMT
Investigating
We are currently investigating an issue impacting Webmail and Email Application access for Professional Email.
Posted Nov 02, 2023 - 08:18 GMT