Email issues
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Feb 16, 2024 - 13:38 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 15, 2024 - 13:29 GMT
Investigating
Some customers are currently experiencing technical issues when attempting to access their Generation 2 mailbox via third-party email clients like Outlook and Gmail or Webmail.
We are looking into this issue and hope to have it resolved as soon as possible.

We apologise for any inconvenience this may cause.
Posted Feb 14, 2024 - 11:27 GMT
This incident affected: Email & Office (Email Hosting).