Microsoft 365 - Activation Issues
Incident Report for
123 Reg –
Resolved
This incident has been resolved.
Posted
Nov
17
,
2023
-
09:16
GMT
Investigating
Customers that have recently purchased our Microsoft 365 Business Professional plan are currently experiencing intermittent issues when attempting to activate their Office apps on desktop devices.
We are looking into this issue and hope to have it resolved as soon as possible. In the meantime, you can access the web versions of these Office apps as usual. For details on how to do this, please read the following article:
https://www.123-reg.co.uk/support/office-365/how-do-i-login-to-my-office-365-online-apps/
.
We apologise for any inconvenience this may cause.
Posted
Nov
15
,
2023
-
13:41
GMT
This incident affected: Email & Office (Microsoft 365).
×
Subscribe to Incident
Subscribe to updates for
Microsoft 365 - Activation Issues
via . You'll receive .