Control Panel Login Issues
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Sep 25, 2023 - 20:05 BST
Investigating
Customers are currently experiencing technical issues when attempting to log in to their 123 Reg Control Panel.
We are looking into this issue and hope to have it resolved as soon as possible. We apologise for any inconvenience this may cause.
Posted Sep 25, 2023 - 19:31 BST