Payment Issues - PayPal
Incident Report for
123 Reg –
Resolved
This incident has been resolved.
Posted
Oct
26
,
2023
-
18:27
BST
Investigating
Customers are currently unable to make any payments for product purchases or renewals via PayPal.
We are investigating this issue and will deploy a fix as soon as possible. We apologise for any inconvenience this may cause.
Posted
Oct
26
,
2023
-
13:55
BST
This incident affected: 123-reg.co.uk (Ordering, Renewals).
×
Subscribe to Incident
Subscribe to updates for
Payment Issues - PayPal
via . You'll receive .