Microsoft 365 Mailboxes - App Activation & Third-Party Client Issues
Incident Report for 123 Reg –
Update
We are continuing to investigate this issue as a high priority and are speaking with Microsoft to resolve this matter.

We apologise for the delay in updates and will share timings for a fix as soon as possible.
Posted Apr 10, 2024 - 15:55 BST
Investigating
Customers may experience issues when attempting to add their Microsoft 365 mailbox to Outlook. We have also received reports that customers are having difficulties activating Microsoft apps.

We are investigating these issues and hope to have them resolved as soon as possible. In the meantime, customers can access their mailboxes/online apps version via Microsoft's official website: https://portal.office.com/

We apologise for any inconvenience this may cause.
Posted Mar 26, 2024 - 15:49 GMT
This incident affects: Email & Office (Microsoft 365).