My Support section unavailable for some customers
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Jun 06, 2023 - 15:02 BST
Investigating
Some customers are experiencing issues when attempting to access the "My Support" section from their account Control Panel, being unable to create/view/respond to tickets.

We are looking into this issue and hope to have it resolved as soon as possible.

If you need assistance, please start a live chat during our opening hours.

We apologise for any inconvenience this may cause.
Posted Jun 02, 2023 - 17:08 BST