Bank Holiday Operational Hours
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted May 28, 2024 - 07:51 BST
Monitoring
We would like to inform our customers that on the 27th of May (Spring Bank Holiday), our phone lines will be closed while the chat functionality will be open from 09:00-16:00.
You can also raise a ticket at http://ticketing.123-reg.co.uk or check out our Support Site at https://www.123-reg.co.uk/support/ for answers to common issues.

Normal service will resume on Tuesday, the 28th of May.
Posted May 24, 2024 - 12:24 BST