Holiday Operational Hours
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Jan 02, 2024 - 14:31 GMT
Monitoring
We would like to inform our customers that during the Holiday season our telephone and chat Customer Support will be operating to an amended schedule.

Phone Support:
25th of December: Closed
26th of December: 8:00 - 16:30
1st of January: Closed


Chat Support:
24-25th of December: Closed
26th of December: 8:00 - 16:30
31st of December - 1st of January: Closed

During the period from the 27th to the 29th of December, we will continue to provide full support coverage, and normal operating hours will resume on Tuesday, January 2nd.

Happy holidays!
Posted Dec 20, 2023 - 09:30 GMT
This incident affected: 123-reg.co.uk (Customer Support).