2-Step Verification Authentication Issues
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Sep 26, 2023 - 13:15 BST
Investigating
We are currently investigating an issue impacting authentication with a 2-Step Verification with an SMS.
Posted Jul 05, 2023 - 11:56 BST