Domain Checkout Issues
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Oct 25, 2023 - 16:21 BST
Investigating
Customers may experience technical issues when attempting to complete a domain purchase on our checkout page.

We are currently investigating this issue and hope to have it resolved as soon as possible. We apologise for any inconvenience this may cause.
Posted Oct 25, 2023 - 14:20 BST
This incident affected: 123-reg.co.uk (Ordering).