Unable to access Professional Email
Incident Report for 123 Reg –
Resolved
This incident has been resolved.
Posted Sep 01, 2023 - 12:36 BST
Investigating
We are currently investigating an issue impacting Webmail and Email Application access for Professional Email service.
Posted Sep 01, 2023 - 08:14 BST